aboutsummaryrefslogtreecommitdiffstats
path: root/wpa_supplicant/README
Commit message (Collapse)AuthorAgeFilesLines
* Add interface matching support with -M, guarded by CONFIG_MATCH_IFACERoy Marples2016-03-221-1/+18
| | | | | | | | | The new wpa_supplicant command line argument -M can be used to describe matching rules with a wildcard interface name (e.g., "wlan*"). This is very useful for systems without udev (Linux) or devd (FreeBSD). Signed-off-by: Roy Marples <roy@marples.name>
* Add EAP-AKA' and EAP-pwd to wpa_supplicant READMEJouni Malinen2016-03-031-1/+5
| | | | | | The EAP methods were missing from the lists. Signed-off-by: Jouni Malinen <jouni@qca.qualcomm.com>
* Update notes about OpenSSL versionsJouni Malinen2016-03-031-7/+1
| | | | | | Obsolete OpenSSL versions 0.9.* are not supported anymore. Signed-off-by: Jouni Malinen <jouni@qca.qualcomm.com>
* Fix some typos in wpa_supplicant README filesJouni Malinen2016-03-031-5/+5
| | | | Signed-off-by: Jouni Malinen <jouni@qca.qualcomm.com>
* Remove -w support from wpa_supplicant READMERoy Marples2016-02-051-2/+1
| | | | | | wpa_supplicant dropped the -w option long long time ago.. Signed-off-by: Roy Marples <roy@marples.name>
* Update copyright notices for the new year 2016Jouni Malinen2016-01-011-1/+1
| | | | Signed-off-by: Jouni Malinen <j@w1.fi>
* Update copyright notices for the new year 2015Jouni Malinen2015-01-261-1/+1
| | | | Signed-off-by: Jouni Malinen <j@w1.fi>
* wpa_supplicant: Add a configuration file for the P2P_DEVICE parametersIlan Peer2014-03-061-1/+2
| | | | | | | | | | | | | | | | | | | | | Add an option to specify a configuration file that can be used to hold the P2P_DEVICE configuration parameters. If this option is not used, the P2P_DEVICE configuration parameters will be read from interface configuration file. Note that it is advised to use this option in some cases such as: If a P2P_DEVICE is supported by the driver, the wpa_supplicant creates a dedicated P2P Device interface, where the configuration file used for the main interface is used. As a consequence, if the configuration file includes network definition etc., the wpa_supplicant will try to perform station specific flows on the P2P Device interface which will fail. If a P2P_DEVICE is supported by the driver and update_config is used, the P2P Device configuration data will override the main interface configuration data. Signed-hostap: Ilan Peer <ilan.peer@intel.com>
* Update copyright notices for the new year 2014Jouni Malinen2014-01-071-1/+1
| | | | Signed-hostap: Jouni Malinen <j@w1.fi>
* Allow external programs to request wpa_radio work itemsJouni Malinen2014-01-071-0/+68
| | | | | | | | | | | | The new control interface command RADIO_WORK can be used by external programs to request radio allocation slots from wpa_supplicant if exclusive radio control is needed, e.g., for offchannel operations. If such operations are done directly to the driver, wpa_supplicant may not have enough information to avoid conflicting operations. This new command can be used to provide enough information and radio scheduling to avoid issues with such cases. Signed-hostap: Jouni Malinen <j@w1.fi>
* Document use of Linux capabilities instead of privileged processJouni Malinen2013-09-291-0/+34
| | | | | | | Linux capabilities cap_net_admin and cap_net_raw can be used to replace need for running wpa_supplicant as a root process. Signed-hostap: Jouni Malinen <j@w1.fi>
* wpa_supplicant: Add -G argument to specify global ctrl groupJouni Malinen2013-05-181-0/+2
| | | | | | | The optional -G<group> command line argument can be used to specify the group that can access the global control interface. Signed-hostap: Jouni Malinen <j@w1.fi>
* wpa_supplicant: Default to nl80211 instead of wextJouni Malinen2013-04-291-10/+13
| | | | | | | | | | nl80211 has obsoleted WEXT as the preferred kernel interface for controlling wireless drivers. Update wpa_supplicant driver interface list order so that nl80211 gets used first if both nl80211 and wext interfaces are included in the build. In addition, update README to reflect the fact that WEXT is obsolete. Signed-hostap: Jouni Malinen <jouni@qca.qualcomm.com>
* Update copyright notices to include year 2013Jouni Malinen2013-01-121-1/+1
| | | | Signed-hostap: Jouni Malinen <j@w1.fi>
* Remove forgotten GPL language from man pages and README filesJouni Malinen2012-04-071-1/+1
| | | | Signed-hostap: Jouni Malinen <j@w1.fi>
* Select the BSD license terms as the only license alternativeJouni Malinen2012-02-111-22/+7
| | | | | | | | | | | | | | | Simplify licensing terms for hostap.git by selecting the BSD license alternative for any future distribution. This drops the GPL v2 alternative from distribution terms and from contribution requirements. The BSD license alternative that has been used in hostap.git (the one with advertisement clause removed) is compatible with GPL and as such the software in hostap.git can still be used with GPL projects. In addition, any new contribution to hostap.git is expected to be licensed under the BSD terms that allow the changes to be merged into older hostap repositories that still include the GPL v2 alternative. Signed-hostap: Jouni Malinen <j@w1.fi>
* Update copyright notices to include year 2012Jouni Malinen2012-01-011-1/+1
| | | | Signed-hostap: Jouni Malinen <j@w1.fi>
* Remove station functionality from hostap and madwifi driver wrappersJouni Malinen2011-11-131-31/+8
| | | | | | | | | This has been obsoleted by the more generic Linux WEXT (driver_wext.c) support. The hostap and madwifi driver wrappers can now be used only with hostapd. The old station interface remains available in releases up to 1.x. Signed-hostap: Jouni Malinen <j@w1.fi>
* Remove unmaintained driver wrappersJouni Malinen2011-11-131-20/+0
| | | | | | | | | The driver wrappers broadcom, iphone, osx, and ralink have not been maintained for a while and it does not look like they will be in the future either. As such, remove them from the development branch. The previous versions will be included in older releases up to 1.x. Signed-hostap: Jouni Malinen <j@w1.fi>
* Make the example action script less likely to result in failuresJouni Malinen2011-04-131-2/+3
| | | | | Use "=" instead of "==" and add an example statement between "then" and "fi".
* Update copyright notices to include the new yearJouni Malinen2011-02-271-1/+1
|
* Remove obsolete drivers wrappers: atmel, ndiswrapper, ipw, hermesJouni Malinen2011-01-301-30/+1
| | | | | | | | | | | | | | | | | | | | | | | | | There is no real reason to maintain these in the current development branch anymore. If someone really needs support for the obsolete driver interfaces, these can be found in older wpa_supplicant branches. driver_atmel.c - vendor-specific interface for ATMEL AT76C5XXx cards - for some old out-of-tree driver; not for the upstream atmel* drivers driver_ndiswrapper.c - vendor-specific interface for an out-of-tree driver - ndiswrapper should work with driver_wext.c, too driver_ipw.c - vendor-specific interface for old ipw2100/2200 driver - the upstream driver works with driver_wext.c (and does not work with the old interface) driver_hermes.c - vendor driver that was not even included in the main wpa_supplicant releases
* Preparations for v0.7.1 releasehostap_0_7_1Jouni Malinen2010-01-161-1/+1
|
* Add cleared deprecation notes on iwl,ndiswrapper,madwifi(sta) wrappersJouni Malinen2009-11-231-2/+2
| | | | | | | These driver wrappers should not be used anymore; WEXT should be used instead. However, there may still be users stuck on older kernel versions that may require driver specific wrappers, so the source code still remains in the repository.
* CONFIG_WIRELESS_EXTENSION is purely internal to the MakefileJohannes Berg2009-07-281-4/+1
|
* Allow multiple driver wrappers to be specified on command lineJouni Malinen2009-02-141-1/+8
| | | | | | For example, -Dnl80211,wext could be used to automatically select between nl80211 and wext. The first driver wrapper that is able to initialize the interface will be used.
* Add comments on the new Broadcom driver not using driver_broadcom.cJouni Malinen2009-01-301-2/+5
| | | | | | The newer Broadcom driver ("hybrid Linux driver") supports Linux wireless extensions and does not need (or even work) with the old driver wrapper.
* Preparations for 0.6.7 releaseJouni Malinen2009-01-061-1/+1
|
* Add RoboSwitch driver interface for wpa_supplicantJouke Witteveen2008-11-181-2/+3
| | | | | | | | | | | | | | | | | | | | | | | | Find attached the patch that creates a new driver: roboswitch. This driver adds support for wired authentication with a Broadcom RoboSwitch chipset. For example it is now possible to do wired authentication with a Linksys WRT54G router running OpenWRT. LIMITATIONS - At the moment the driver does not support the BCM5365 series (though adding it requires just some register tweaks). - The driver is also limited to Linux (this is a far more technical restriction). - In order to compile against a 2.4 series you need to edit include/linux/mii.h and change all references to "u16" in "__u16". I have submitted a patch upstream that will fix this in a future version of the 2.4 kernel. [These modifications (and more) are now included in the kernel source and can be found in versions 2.4.37-rc2 and up.] USAGE - Usage is similar to the wired driver. Choose the interfacename of the vlan that contains your desired authentication port on the router. This name must be formatted as <interface>.<vlan>, which is the default on all systems I know.
* Re-initialize hostapd/wpa_supplicant git repository based on 0.6.3 releaseJouni Malinen2008-02-281-0/+1024